LAB1 - Tong Hop (1122060417)

  • View
    78

  • Download
    9

Embed Size (px)

Transcript

  • LAB 1 Ngy 27/06/2012

    GV: Thy Nguyn c Quang SV: Lng Th Quang

    B GIO DC V O TO

    TRNG I HC T UT CNG NGH TP.HCM HUTECH

    KHOA C O T C

    ---------o0o---------

    BO CO TI MN

    QUN TR MNG

    LAB Tng hp

    GV : Thy Nguyn c Quang

    SV : Lng Th Quang

    Lp : C11QM15

    MSSV: 1122060417

  • LAB 1 Ngy 27/06/2012

    GV: Thy Nguyn c Quang SV: Lng Th Quang

    I. Ni dung v yu cu bi LAB:

    1) M hnh:

    2) M t :

    Cng ngh kt ni : M hnh gm 6 router v mt Frame Relay Switch.

    Cc router c gn tn R1, R2, R3, R4, R5, R6 nh trn hnh v.

    R1, R2 v R3 kt ni vi nhau bng cng ngh chuyn mch khung (Frame Relay)

    vi 2 PVC gia R1 vi R2 v gia R1 vi R3.

    S dng giao thc nh tuyn RIP cho tt c cc router.

    R1 kt ni vi my tnh tht qua card mng loopback v R6 kt ni vo my tnh

    o Vmware.

    3) Phn mm v cng c cn thit:

    RAM v CPU mnh thc hin.

    Phn mm gi lp thit b h tng mng GNS3.

    Phn mm gi lp h iu hnh VMware Workstation.

    Phn mm bt gi tin Wireshark.

    Phn mm bt lu lng Netflow Analyzer.

    Phn mm gim st thit b PRTG Network Monitor.

    Mt s phn mm gi in thoi v tp cng c h tr Solarwinds.

  • LAB 1 Ngy 27/06/2012

    GV: Thy Nguyn c Quang SV: Lng Th Quang

    4) Yu cu:

    To v bt lu lng i qua cng S1/0 ca R4 v th hin Y trn hnh chp

    phn mm Netflow vi a ch IP y ca lu lng:

    HTTP, HTTPS, TELNET, SSH, NTP, Netmeeting, FTP, TFTP, DNS, SIP, H323,

    Kerberos, SQL, SNMP, RADIUS, TACACS, SMTP, SNMP Trap, RTP & RTCP,

    SCCP, RSVP, POP, DHCP.

    Dng cng c Cisco Tool Config Download ly cu hnh ca tt c cc

    Router trong m hnh k c Frame Relay Switch. Copy cu hnh ny vo bi np.

    Dng lnh Show ip route xem bng nh tuyn ca tt c cc router v copy

    vo bi np.

    Dng phn mm WireShark bt cc lu lng 4.1 trn cng loopback ca

    my tnh tht.

    My C2 c th vo internet.

    Bt trap gi v in thoi di ng khi c thay i cu hnh trn R3.

    Th hin s u tin lu lng t cao n thp trng DSCP cho cc lu lng

    theo th t sau : RTP, Netmeeting, TELNET, SSH.

    Cu hnh cho giao thc RTP chim 25% tng bng thng, Netmeeting 15% tng

    bng thng v 60% cn li dnh cho cc giao thc khc.

  • LAB 1 Ngy 27/06/2012

    GV: Thy Nguyn c Quang SV: Lng Th Quang

    II. Thc hin bi LAB:

    M t trn s :

    - My C1 ng vai tr l my tht ci t cc dch v v phn mm phn yu cu

    ca bi LAB. My c 2 card mng, 1 card c th vo Internet v 1 card ni vo h

    thng nh m hnh trn.

    - R1 l router c cu hnh chng thc TACACS+, DHCP Relay Agent cp a

    ch h cho my DHCP Server v RSVP Sender.

    - R2 l router lm RADIUS client v c trin khai dch v Telnet.

    - R3 l router cu hnh SNMP, SNMP Trap my client c th gim st.

    - R4 l router ng vai tr lm NTP Server cc router khc ng b thi gian,

    DHCP Server v cho php bt lu lng cng S1/0.

    - R5 l router trin khai dch v Cisco Call Manager Express cho php 2 my client

    v server gi thoi cho nhau thng qua giao thc Skinny.

    - R6 l router cho php ssh truy cp t xa v l RSVP Reservation.

    - My C2 l my Windows Server 2k3 ci t cc dch v: Exchange Server, SQL

    Server, Cisco ACS, IIS, IAS, DNS, FTP, AD, Netmeeting, Cisco IP

    Communicator.

  • LAB 1 Ngy 27/06/2012

    GV: Thy Nguyn c Quang SV: Lng Th Quang

    1. Hnh chp cc lu lng gi tin bt c khi i qua cng S1/0 ca Router R4:

  • LAB 1 Ngy 27/06/2012

    GV: Thy Nguyn c Quang SV: Lng Th Quang

  • LAB 1 Ngy 27/06/2012

    GV: Thy Nguyn c Quang SV: Lng Th Quang

    2. S dng cng c Cisco Tool Download Config ly file cu hnh t cc router

    v Frame Relay Switch.

    Router R1 !* R1.CiscoConfig !* IP Address : 10.0.0.17 !* Community : private !* Downloaded 6/28/2012 11:00:42 PM by SolarWinds Config Transfer Engine Version 5.5.0 ! ! Last configuration change at 05:57:02 GMT Fri Jun 29 2012 ! NVRAM config last updated at 05:57:32 GMT Fri Jun 29 2012 ! version 12.4 service timestamps debug datetime msec service timestamps log datetime msec no service password-encryption no service dhcp ! hostname R1

    ! boot-start-marker boot-end-marker ! ! aaa new-model ! ! aaa authentication login default group tacacs+ aaa authorization exec default group tacacs+ ! aaa session-id common clock timezone GMT 7 ! ! ip cef no ip domain lookup ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! !

  • LAB 1 Ngy 27/06/2012

    GV: Thy Nguyn c Quang SV: Lng Th Quang

    class-map match-all telnet match access-group 113

    class-map match-all netmeeting match access-group 112

    class-map match-all ssh match access-group 114

    class-map match-all rtp match access-group 111 ! !

    policy-map dscp class rtp

    set dscp cs6 class netmeeting

    set dscp cs5 class telnet

    set dscp cs4 class ssh set dscp cs3

    policy-map bandwidth class rtp

    priority percent 25 class netmeeting

    priority percent 15 class class-default fair-queue ! ! ! ! ! !

    interface FastEthernet0/0 no ip address shutdown duplex half !

    interface Serial1/0 no ip address encapsulation frame-relay serial restart-delay 0 fair-queue 64 256 37 frame-relay lmi-type ansi ip rsvp bandwidth !

    interface Serial1/0.96 point-to-point ip address 192.168.2.17 255.255.255.0 frame-relay interface-dlci 96 ip rsvp bandwidth !

    interface Serial1/0.98 point-to-point ip address 192.168.1.17 255.255.255.0 frame-relay interface-dlci 98 ip rsvp bandwidth !

    interface Serial1/1 no ip address

  • LAB 1 Ngy 27/06/2012

    GV: Thy Nguyn c Quang SV: Lng Th Quang

    shutdown serial restart-delay 0 !

    interface Serial1/2 no ip address shutdown serial restart-delay 0 !

    interface Serial1/3 no ip address shutdown serial restart-delay 0 !

    interface Serial1/4 no ip address shutdown serial restart-delay 0 !

    interface Serial1/5 no ip address shutdown serial restart-delay 0 !

    interface Serial1/6 no ip address shutdown serial restart-delay 0 !

    interface Serial1/7 no ip address shutdown serial restart-delay 0 !

    interface FastEthernet2/0 ip address 10.0.0.17 255.255.255.0 ip helper-address 192.168.3.18 duplex auto speed auto ip rsvp bandwidth !

    interface FastEthernet2/1 no ip address shutdown duplex auto speed auto !

    router rip network 10.0.0.0 network 192.168.0.0 network 192.168.1.0 network 192.168.2.0 ! ! no ip http server no ip http secure-server ! ip rsvp sender 20.0.0.18 10.0.0.18 TCP 0 0 10.0.0.18 FastEthernet2/0 10 5 !

  • LAB 1 Ngy 27/06/2012

    GV: Thy Nguyn c Quang SV: Lng Th Quang

    access-list 1 permit any access-list 111 permit tcp any any eq 3230 access-list 111 permit udp any any eq 3230 access-list 112 permit tcp any any eq 3389 access-list 113 permit tcp any any eq telnet access-list 114 permit tcp any any eq 22 snmp-server community public RO snmp-server community private RW ! ! tacacs-server host 20.0.0.18 tacacs-server key 123456 ! ! control-plane ! ! ! ! ! !

    gatekeeper shutdown ! !

    line con 0 exec-timeout 0 0 logging synchronous stopbits 1

    line aux 0 stopbits 1 line vty 5 15 ! ntp clock-period 17179862 ntp server 192.168.3.18 !

    end

    Router R2 !* R2.CiscoConfig !* IP Address : 192.168.1.18 !* Community : private !* Downloaded 6/28/2012 11:01:29 PM by SolarWinds Config Transfer Engine Version 5.5.0 ! version 12.4 service timestamps debug datetime msec service timestamps log datetime msec no service password-encryption ! hostname R2

    ! boot-start-marker boot-end-marker ! enable secret 5 $1$cDoE$a3C5tIVf.YFvck/OaeGw3/ !

  • LAB 1 Ngy 27/06/2012

    GV: Thy Nguyn c Quang SV: Lng Th Quang

    aaa new-model ! ! aaa authentication login Radius_Router group radius aaa authorization exec Radius_Router group radius ! aaa session-id common ! ! ip cef no ip domain lookup ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! !

    class-map match-all telnet match access-group 113

    class-map match-all netmeeting match access-group 112

    class-map match-all ssh match access-group 114

    class-map match-all rtp match access-group 111 ! !

    policy-map dscp class rtp

    set dscp cs6 class netmeeting

    set dscp cs5 class telnet

    set dscp cs4 class ssh set dscp cs3

    policy-map bandwidth class rtp

    priority percent 25 class netmeeting

    priority percent 15 class class-default fair-queue !

  • LAB 1 Ngy 27/06/2012

    GV: Thy Nguyn c Quang SV: Lng Th Quang

    ! ! ! ! !

    interface FastEthernet0/0 no ip address shutdown duplex half !

    interface Serial1/0 no ip address encapsulation frame-relay serial restart-delay 0 fair-queue 64 256 37 frame-relay lmi-type ansi ip rsvp bandwidth !

    interface Serial1/0.89 point-to-point ip address 192.168.1.18 255.255.255.0 frame-relay interface-dlci 89 ip rsvp bandwidth !

    interface Serial1/1 no ip address shutdown serial restart-delay 0 !

    interface Serial1/2 no ip address shutdown serial restart-delay 0 !

    interface Serial1/3 no ip address shutdown serial restart-delay 0 !

    interface Serial1/4 no ip address shutdown serial restart-delay 0 !

    interface Serial1/5 no ip address shutdown serial restart-delay 0 !

    interface Serial1/6 no ip address shutdown serial restart-delay 0 !

    interface Serial1/7 no ip address shutdown serial restart-delay 0 !

  • LAB 1 Ngy 27/06/2012

    GV: Thy Nguyn c Quang SV: Lng Th Quang

    router rip network 192.168.1.0 ! ! no ip http server no ip http secure-server ! ! access-list 111 permit tcp any any eq 3230 access-l