Construcao de Algoritmos - Aula 07

  • View
    20

  • Download
    1

Embed Size (px)

Transcript

Slide 1

Disciplina: Constr. de Algoritmos e Prog. de SistemasProfessor: Jeovane RegesCaxias MA2016ACULDADE DE CINCIAS E TECNOLOGIA DO MARANHO

1

Link Drive

bit.ly/ads-algoritmos

2

3 Algoritmos

4Exemplos Resolvidos

5Problema IFaa um algoritmo que leia um nmero qualquer e imprima o quadrado desse nmero caso ele seja positivo.

Algoritmos Problema ISolucionando o problema...

6

Entrada:Um nmero qualquernumero 8

Processamento:Verificar se o numero positivo.// se o "numero" for maior do que zero, ento ele positivo

Sada:Quadrado do numero fornecido.

Algoritmos Comandos de DecisesResoluo do Problema I

7

algoritmo "Problema 01"var numero: inteiroinicio escreva("Digite um valor: ") leia(numero)

se (numero > 0) entao escreval(Quad(numero)) fimsefimalgoritmo

8Problema IIFaa um algoritmo que leia o ano atual e o ano de nascimento de uma pessoa. Em seguida, escreva uma mensagem que diga se ela poder votar este ano.// para uma pessoa votar ele deve ter uma idade maior ou igual a 16 anos.

Algoritmos Problema IISolucionando o problema...

9

Entrada:Ano de nascimento e ano atualano_nasc 1990ano_atual 2016

Processamento:idade ano_atual - ano_nasc // 25 anosSe a idade for maior ou igual 16 entao eleitor

Sada:Poder votar.

Algoritmos Comandos de DecisesResoluo do Problema II

10

algoritmo "Problema 02"var ano_nasc, ano_atual, idade: inteiroinicio ano_nasc 1990 ano_atual 2016 idade ano_atual - ano_nasc

se (idade >= 16) entao escreva("Poder votar") fimsefimalgoritmo

11Problema IIIFaa um algoritmo que leia um nmero e apresente-o caso seja divisvel por 2, mas no simultaneamente por 2 e 3.

Algoritmos Problema IIISolucionando o problema...

12

Entrada:Um nmero qualquernum 14

Processamento :

Sada:Apresentar o nmero fornecido pelo usurio.142(0)7

143(2)4

num

Algoritmos Comandos de DecisesResoluo do Problema III

13

algoritmo "Problema 03"var num: inteiroinicio escreva("Digite um valor: ") leia(num)

se ((num % 2 = 0) E (num % 3 0)) entao escreval(num) fimsefimalgoritmo

14Problema IVFaa um programa que leia um numero e apresente:A raiz quadrada caso seja positivoO cubo caso seja negativo

Algoritmos Problema IVSolucionando o problema...

15

Entrada:Um nmero qualquernumero 8

Processamento:Verificar se o numero positivo ou negativo.Positivo: Raiz quadradaNegativo: Elevado ao cuboSada:Raiz quadrada do numero.Ou o numero elevado ao cubo.

Algoritmos Comandos de DecisesResoluo do Problema IV

16

algoritmo "Problema 04"var numero: inteiroinicio escreva("Digite um valor: ") leia(numero)

se (numero > 0) entao escreval(RaizQ(numero)) senao escreval(Exp(numero, 3)) fimsefimalgoritmo

17Problema VDada a idade e o tempo de servio de um trabalhador, escreva se ele pode ou no se aposentar. As condies para aposentadoria so:Ter pelo menos 65 anos; Ter trabalhado pelo menos 30 anos;Ter pelo menos 60 anos e trabalhado pelo menos 25 anos.

Algoritmos Problema VSolucionando o problema...

18

Entrada:Idade e tempo de servioIdade 60tempo_serv 27

Processamento:Se tem pelo menos 65 anos;Senao se trabalhou pelo menos 30 anos;Senao se tem pelo menos 60 anos e trabalhou pelo menos 25 anos.

Sada:Pode se aposentar.

Algoritmos

19

algoritmo "Problema 05"var idade, tempo_serv: inteiroinicio idade 60 tempo_serv 27 se (idade >= 65) entao escreval("Pode se aposentar") senao se (tempo_serv >= 30) entao escreval("Pode se aposentar") senao se ((idade >= 60) E (tempo_serv >= 25)) ento escreval("Pode se aposentar") fimse fimse fimsefimalgoritmoResoluo do Problema V

20Problema VIFaa um algoritmo que dados trs nmeros inteiros, apresente-os em ordem crescente.

Algoritmos Problema VISolucionando o problema...

21

Entrada:Trs nmeros quaisquer...n1 11n2 10n3 9

Processamento:Encontrar o 3. maior, 2. maior e 1. maior. // comparar os valores uns com os outros

Sada:Apresent-los em ordem crescente.

Algoritmos

22

algoritmo "Problema 06"var n1, n2, n3: inteiroinicio n1 11 n2 10 n3 12 se ((n1 > n2) E (n2 > n3)) entao escreval(n3, n2, n1) senao se ((n1 > n3) E (n3 > n2)) entao escreval(n2, n3, n1) senao // verifica as outras condies fimse fimsefimalgoritmoResoluo do Problema VI

23Problema VIIUsando o comando escolha .. caso, faa um algoritmo que leia um nmero inteiro entre 1 e 7 e imprima o dia da semana correspondente a esse nmero.

Algoritmos Problema VIISolucionando o problema...

24

Entrada:Um nmero que represente um dia da semanadia 2

Processamento:Verificar qual dia da semana o numero representa.

Sada:1 Domingo2 Segunda-feira3 Tera-feira

AlgoritmosComandos de Decises

25

algoritmo "Problema 07"var dia: inteiroinicio escreva("Digite um numero: ") leia(dia) escolha (dia) caso 1 escreval("Domingo") caso 2 escreval("Segunda-feira") outrocaso escreval("Dia invlido") fimescolha fimalgoritmoResoluo do Problema VII